There is a problem with the data provider. Matches are temporarily unavailable
Incident Report for Betlab
Resolved
This incident has been resolved!
Posted Oct 28, 2022 - 21:35 UTC
Update
We're still working on fixing
Posted Oct 28, 2022 - 20:45 UTC
Update
We're working on preparing fix
Posted Oct 28, 2022 - 14:47 UTC
Identified
There is a problem with the data provider. Matches are temporarily unavailable
Posted Oct 28, 2022 - 12:57 UTC
This incident affected: Services (Bots) and Website.